主题制作平台网页:灵通信精选主图指标:黄金45°角出场(源码免
本文摘要: 我们好,今天跟我们分享一个黄金45°角出场的主图指标指标就不多介绍了,简略明了,源码分享在下方,我们自行去测试源码{N:1 100 5 M:1 100 13} 利:WINNER(CLOSE)*100,NODRAW,COLORRED; V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,2
我们好,今天跟我们分享一个黄金45°角出场的主图指标

指标就不多介绍了,简略明了,源码分享在下方,我们自行去测试

源码


{N:1 100 5 M:1 100 13}

利:WINNER(CLOSE)*100,NODRAW,COLORRED;

V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

V2:=(1-7/100)*(DMA(CLOSE,V1));

V3:=(1+7/100)*(DMA(CLOSE,V1));

V5:=MA((LOW+HIGH+CLOSE)/3,5);

MA1:=MEMA(CLOSE,5);

MA2:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;

MA3:=IF(MA2>0,MA2,MA2);

3:MA(C,3);5:MA(C,5);8:MA(C,8); 21:MA(C,21);

34:MA(C,34);55:MA(C,55);72:MA(C,72);89:MA(C,89);125:MA(C,125);144:MA(C,144);

支撑:REFDATE(V2,DATE),POINTDOT,LINETHICK3,COLORCC66FF;

阻力:REFDATE(V3,DATE),POINTDOT,LINETHICK3,COLORGREEN;

MA13:MA(CLOSE,M),COLORFF9900,LINETHICK2;

VAR1:=CLOSE=HHV(C,4) AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);

VAR2:=CLOSE=HHV(C,4) AND REF(C,1)=LLV(C,4);

VAR3:=CLOSE=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);

VAR4:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);

VAR5:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);

VAR6:=V5>REF(V5,1) AND REF(V5,1)<REF(V5,2);

VAR7:=LOW<HHV(V5,13) AND HIGH>HHV(V5,13) AND CLOSE>REF(C,1) AND CLOSE>OPEN;

VAR8:=VAR7 AND COUNT(VAR6,2);

VAR9:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);

VAR10:=EMA(MA(C,13),13);

VAR11:=FILTER((LLV(VAR9,2)=LLV(VAR9,7) AND COUNT(VAR9<0,2) AND CROSS(VAR9,MA(VAR9,2)))=1,5);

VAR12:=FILTER((HHV(VAR9,2)=HHV(VAR9,7) AND COUNT(VAR9>50,2) AND CROSS(MA(VAR9,2),VAR9))=1,1);

VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;

VAR14:=FILTER(((CROSS(VAR13,0) OR CROSS(C,VAR10)) AND VAR11)=1,3);

VAR15:=MA(C,18)>=REF(MA(C,18),3) AND CROSS(C,MA(C,18));

VAR16:=VAR8 AND NOT(REF(VAR8,1));

强攻:IF(MA3>REF(MA3,1) AND MA3>=0,MA13,DRAWNULL),COLORYELLOW,LINETHICK2;

回调:IF(MA3<REF(MA3,1) AND MA3>0,MA13,DRAWNULL),COLORGREEN,LINETHICK2;

{KDJ}

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

金叉:=CROSS(J,D);

死叉:=CROSS(D,J);

买1:=(VAR14 OR VAR15) AND VAR11;

买2:=(VAR14 OR VAR15) AND VAR4;

买3:=(VAR14 OR VAR15) AND VAR2;

买4:=(VAR2 AND VAR11) OR (VAR4 AND VAR11);

买5:=(金叉 AND VAR4) OR (金叉 AND VAR2) OR (金叉 AND VAR11);

{涨停}

STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),COLOR00FFFF;

{跌停}

STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),COLORGREEN;

{蓝}

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF7700;

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;

STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;

{红}

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR000099;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR0000FF;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;

{绿}

STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,3,0),COLOR009900;

STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,2.2,0),COLOR00BB00;

STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,1.5,0),COLOR00DD00;

STICKLINE(VAR3,OPEN,(OPEN+CLOSE)/2,0.5,0),COLOR00FF00;

{灰}

STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,3,0),COLOR999999;

STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;

STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,1.5,0),COLORDDDDDD;

STICKLINE(VAR4,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORFFFFF;

STICKLINE(金叉,OPEN,CLOSE,0.5,0),COLORYELLOW;

STICKLINE(死叉,OPEN,CLOSE,0.5,0),COLOR000099;

DRAWICON(VAR16,LOW*0.96,7);

DRAWICON(买1 OR 买2 OR 买3 OR 买4 OR 买5,LOW*0.99,1);

DRAWICON(死叉 OR VAR12 OR CROSS(40,VAR9),HIGH+0.01,2);

EMA13:=EMA(C,13),COLORWHITE;

EMA21:=EMA(C,21),COLORYELLOW;

EMA34:=EMA(C,34),COLORFF00FF;

EMA60:=MA(C,60),COLORFFCC66;

VAR22:=(2*CLOSE+HIGH+LOW)/4;

VAR33:=IF(YEAR>=2099 AND MONTH>2,0,1);

VAR44:=LLV(LOW,5); VAR55:=HHV(HIGH,4);

散户:=EMA((VAR22-VAR44)/(VAR55-VAR44)*100,4)*VAR33;

庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR33;

LC:=REF(CLOSE,1);

RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

DRAWTEXT(CROSS(84,RSI) , HIGH,'←-----逃'),COLORGREEN;

VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);

VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);

DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'←---大胆搏 '),COLORYELLOW;

VAR51:=3;

VAR52:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) - (2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));

DRAWTEXT(CROSS(VAR52,VAR51), LOW,'←启动')COLORMAGENTA;

X1:=(C+L+H)/3;

BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;

EMA8:=EMA(C,8);

DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),

EMA8,'∠45上升'),COLORWHITE;

K_T1:=MA(H,5)*(1+5/100);

DRAWTEXT(CROSS(K_T1,C),H,'跑'),COLORFF8C00;

DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);

DRAWTEXT(FILTER(买=1,5),LOW-0.03,'拉升'),COLORFFDE00;

{日:=150;昨前:=3;

高1:=REF(HHV(H,日),昨前);

低1:=REF(LLV(L,日),昨前);

H1:=高1-(高1-低1)*0.191;

H2:=高1-(高1-低1)*0.382;

H3:=高1-(高1-低1)*0.5;

H4:=高1-(高1-低1)*0.618;

H5:=高1-(高1-低1)*0.809;

顶:REFDATE(高1,DATE),COLORRED;

一0.809:REFDATE(H1,DATE),COLORYELLOW;

二0.618:REFDATE(H2,DATE),COLORMAGENTA;

三0.500:REFDATE(H3,DATE),COLORWHITE;

四0.382:REFDATE(H4,DATE),COLORGREEN;

五0.191:REFDATE(H5,DATE),COLORYELLOW;

低:REFDATE(低1,DATE),COLORRED;};






喜欢的朋友点下重视,在下方留言评论,转发分享

更多指标战法,继续更新

【免责声明】本文仅代表作者或发布者个人观念,不代表(www.lmnkf.cn)及其所属公司官方发声,对文章观念有疑义请先联络作者或发布者自己修正,若内容触及侵权或违法信息,请先联络发布者或作者删除,若需我们协助请联络平台管理员,Emailcxb5918(本平台不支撑其他投诉反馈渠道,谢谢合作)。若需要学习以上相关常识请到巨推学院观看视频教程,网站地址www.tsllg.cn。

相关内容